在python3.9下如何安裝scrapy的方法

本文主要介紹瞭在python3.9下如何安裝scrapy的方法,分享給大傢,具體如下:

安裝命令:

pip install scrapy -i https://pypi.douban.com/simple

如果安裝失敗的話像下圖這樣(解決方法如下):

出現原因:我在python3.7版本裡安裝沒有出現這樣的情況,但是在3.9版本中出現瞭這樣的錯誤。在這裡scrapy會自動將一些常用的配置包給我們安裝上,但是twisted這個包安裝的時候會報錯。

解決方法:

1.面對這個問題,其實我們無法通過用pip install Twisted -i https://pypi.douban.com/simple直接安裝.我們采用安裝whl(whl是文件類型)的方式來安裝twisted. https://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted (這是下載鏈接,所有的第三方庫都在這個網頁裡)

2.在上面的鏈接中我們找到自己對應的版本,我的系統是win64,所以需要安裝第一個,點擊下載它:

 3.在下載好Twisted之前我們要安裝wheel,這樣我們才能安裝Twisted.whl.

3.1打開命令行在自己的python文件夾下安裝

3.2然後輸入:

pip install wheel -i https://pypi.douban.com/simple

 

 4.我把Twisted.whl放在瞭D:\software\python3.9裡,現在來安裝它

pip install D:\software\python3.9\Twisted-20.3.0-cp39-cp39-win_amd64.whl

5.最後安裝scrapy

pip install scrapy -i https://pypi.douban.com/simple

到此這篇關於在python3.9下如何安裝scrapy的方法的文章就介紹到這瞭,更多相關python3.9安裝scrapy內容請搜索WalkonNet以前的文章或繼續瀏覽下面的相關文章希望大傢以後多多支持WalkonNet!