關於Intellij idea 報錯:Error : java 不支持發行版本5的問題

推薦解決方式:https://www.jb51.net/article/205959.htm

如按上述方式解決瞭問題,下文可以忽略。

     在Intellij idea中新建瞭一個Maven項目,運行時報錯如下:Error : java 不支持發行版本5

       本地運行用的是JDK9,測試Java的Stream操作,報錯應該是項目編譯配置使用的Java版本不對,需要檢查一下項目及環境使用的Java編譯版本配置。

       《1》在Intellij中點擊“File” –>“Project Structure”,看一下“Project”和“Module”欄目中Java版本是否與本地一致:

如果不一致,改成本地使用的Java版本。

      《2》點擊“Settings”–>“Bulid, Execution,Deployment”–>“Java Compiler”,Target bytecode version設為本地Java版本。(可以在Default Settings中把Project bytecode version 一勞永逸地配置成本地Java版本)

Default Settings:

       以上兩步都配置好之後,重新運行應該就不會報上述錯誤瞭。

一勞永逸的改法:

感謝評論區另一位博友 Fumoon 提供的方案:https://www.jb51.net/article/205959.htm

到此這篇關於關於Intellij idea 報錯:Error : java 不支持發行版本5的問題的文章就介紹到這瞭,更多相關idea 報錯java 不支持發行版本內容請搜索WalkonNet以前的文章或繼續瀏覽下面的相關文章希望大傢以後多多支持WalkonNet!