永久解決 Intellij idea 報錯:Error :java 不支持發行版本5的問題

初次在IDEA使用maven的時候遇到的問題

在這裡插入圖片描述

搜索之後得到解決方案
idea 報錯:Error : java 不支持發行版本5
實際測試後該博主提供的方法可以解決.
但是每次創建新項目的時候都要設置一次.

這裡提供一個 一勞永逸的方法

在 maven地址\conf\setting.xml
中設置默認jdk版本…

把圖中代碼添加到…中

在這裡插入圖片描述

我使用的是jdk11

復制代碼時需要修改成自己的jkd版本
例如jkd8

code:

 <profile>
  <id>development</id>
  <activation>
  <jdk>1.8</jdk>
  <activeByDefault>true</activeByDefault>
  </activation>
  <properties>
  <maven.compiler.source>1.8</maven.compiler.source>
  <maven.compiler.target>1.8</maven.compiler.target>
  <maven.compiler.compilerVersion>1.8</maven.compiler.compilerVersion>
  </properties>
 </profile>

並且復制一份到 C:\Users\本地用戶名\.m2中
我的是

在這裡插入圖片描述

設置完成後,新建maven項目,不用修改設置即可編譯成功.

在這裡插入圖片描述

到此這篇關於永久解決 Intellij idea 報錯:Error :java 不支持發行版本5的問題的文章就介紹到這瞭,更多相關idea 報錯java 不支持發行版本內容請搜索WalkonNet以前的文章或繼續瀏覽下面的相關文章希望大傢以後多多支持WalkonNet!